Topic: Another one bugfix for FD "blocks must have rank 2"

FuncDesigner sometimes yields the error "blocks must have rank 2" (this message is due to scipy.sparse prematurity that cannot correctly handle flatten numpy arrays), I hope the bugfix I have committed is enough (however, maybe it will trigger from other code lines).